Docs | Support

workforce-data-initiative/skills-ml

requirements.txt


Package Current version Latest version Status Python 3
pandas ==0.23.4 1.3.3 outdated Python 3  
requests ==2.20.1 2.26.0 outdated Python 3  
scikit-learn ==0.20.0 1.0 outdated Python 3  
scipy ==1.1.0 1.7.1 outdated Python 3  
pytest ==3.10.1 6.2.5 outdated Python 3  
Elasticsearch ==6.3.1 7.15.0 outdated Python 3  
annoy ==1.14.0 1.17.0 outdated Python 3  
unicodecsv ==0.14.1 0.14.1 up-to-date Python 3  
us ==1.0.0 2.0.2 outdated Python 3  
Sqlalchemy ==1.2.14 1.4.25 insecure Python 3  
geocoder ==1.38.1 1.38.1 up-to-date Python 3  
psycopg2 ==2.7.6.1 2.9.1 outdated Python 3  
alembic ==1.0.2 1.7.3 outdated Python 3  
retrying ==1.3.3 1.3.3 up-to-date Python 3  
fiona ==1.8.0 1.8.20 outdated Python 3  
shapely ==1.6.4.post2 1.7.1 outdated Python 3  
filelock ==3.0.10 3.1.0 outdated Python 3  
bs4 ==0.0.1 0.0.1 up-to-date Python 3  
lxml ==4.2.5 4.6.3 insecure Python 3  
fuzzywuzzy ==0.17.0 0.18.0 outdated Python 3  
python-Levenshtein ==0.12.0 0.12.2 outdated Python 3  
dickens ==1.0.1 1.0.1 up-to-date Python 3  
skills-utils ==0.4.0 0.4.0 up-to-date Python 3  
s3fs ==0.1.6 2021.9.0 outdated Python 3  
dill ==0.2.8.2 0.3.4 outdated Python 3  
toolz ==0.9.0 0.11.1 outdated Python 3  
multiprocess ==0.70.6.1 0.70.12.2 outdated Python 3  

requirements_addon.txt


tensorflow ==1.12.0 2.6.0 insecure Python 3  

requirements_dev.txt


codecov ==2.0.15 2.1.12 insecure Python 3  
httpretty ==0.9.6 1.1.4 outdated Python 3  
freezegun ==0.3.11 1.1.0 outdated Python 3  
mock ==2.0.0 4.0.3 outdated Python 3  
moto ==1.3.7 2.2.8 outdated Python 3  
pytest-cov ==2.6.0 2.12.1 outdated Python 3  
pytest ==3.10.1 6.2.5 outdated Python 3  
testing.postgresql ==1.3.0 1.3.0 up-to-date Python 3  
tox ==3.5.3 3.24.4 outdated Python 3  
bumpversion ==0.5.3 0.6.0 outdated Python 3  
mkdocs ==1.0.4 1.2.2 outdated Python 3  
mkdocs-material ==3.0.6 7.3.0 insecure Python 3  
factory_boy ==2.11.1 3.2.0 outdated Python 3  
jupyter ==1.0.0 1.0.0 up-to-date Python 3  

requirements_viz.txt


graphviz ==0.10.1 0.17 outdated Python 3