Docs | Support

cookiecutter/cookiecutter-django

docs/requirements.txt


Package Current version Latest version Status Python 3
sphinx ==4.3.2 4.4.0 outdated Python 3  
sphinx-rtd-theme ==1.0.0 1.0.0 up-to-date Python 3  

requirements.txt


cookiecutter ==1.7.3 1.7.3 up-to-date Python 3  
sh ==1.14.2 1.14.2 up-to-date Python 3  
binaryornot ==0.4.4 0.4.4 up-to-date Python 3  
black ==21.12b0 21.12b0 up-to-date Python 3  
isort ==5.10.1 5.10.1 up-to-date Python 3  
flake8 ==4.0.1 4.0.1 up-to-date Python 3  
flake8-isort ==4.1.1 4.1.1 up-to-date Python 3  
pre-commit ==2.16.0 2.16.0 up-to-date Python 3  
tox ==3.24.5 3.24.5 up-to-date Python 3  
pytest ==6.2.5 6.2.5 up-to-date Python 3  
pytest-cookies ==0.6.1 0.6.1 up-to-date Python 3  
pytest-instafail ==0.4.2 0.4.2 up-to-date Python 3  
pyyaml ==6.0 6.0 up-to-date Python 3  
PyGithub ==1.55 1.55 up-to-date Python 3  
gitpython ==3.1.26 3.1.26 up-to-date Python 3  
jinja2 ==3.0.3 3.0.3 up-to-date Python 3  
requests ==2.27.1 2.27.1 up-to-date Python 3  

{{cookiecutter.project_slug}}/requirements/production.txt


gunicorn ==20.1.0 20.1.0 up-to-date Python 3  
psycopg2 ==2.9.3 2.9.3 up-to-date Python 3  
Collectfast ==2.2.0 2.2.0 up-to-date Python 3  
sentry-sdk ==1.5.2 1.5.2 up-to-date Python 3  
hiredis ==2.0.0 2.0.0 up-to-date Python 3  
django-storages[boto3] ==1.12.3 1.12.3 up-to-date Python 3  
django-storages[google] ==1.12.3 1.12.3 up-to-date Python 3  
django-anymail[mailgun] ==8.4 8.4 up-to-date Python 3  
django-anymail[amazon_ses] ==8.4 8.4 up-to-date Python 3  
django-anymail[mailjet] ==8.4 8.4 up-to-date Python 3  
django-anymail[mandrill] ==8.4 8.4 up-to-date Python 3  
django-anymail[postmark] ==8.4 8.4 up-to-date Python 3  
django-anymail[sendgrid] ==8.4 8.4 up-to-date Python 3  
django-anymail[sendinblue] ==8.4 8.4 up-to-date Python 3  
django-anymail[sparkpost] ==8.4 8.4 up-to-date Python 3  
django-anymail ==8.4 8.4 up-to-date Python 3  

{{cookiecutter.project_slug}}/requirements/base.txt


pytz ==2021.3 2021.3 up-to-date Python 3  
python-slugify ==5.0.2 5.0.2 up-to-date Python 3  
Pillow ==9.0.0 9.0.0 up-to-date Python 3  
rcssmin ==1.1.0 1.1.0 up-to-date Python 3  
argon2-cffi ==21.3.0 21.3.0 up-to-date Python 3  
whitenoise ==5.3.0 5.3.0 up-to-date Python 3  
redis ==4.1.0 4.1.0 up-to-date Python 3  
hiredis ==2.0.0 2.0.0 up-to-date Python 3  
celery ==5.2.3 5.2.3 up-to-date Python 3  
django-celery-beat ==2.2.1 2.2.1 up-to-date Python 3  
flower ==1.0.0 1.0.0 up-to-date Python 3  
uvicorn[standard] ==0.17.0 0.17.0 up-to-date Python 3  
django ==3.2.11 4.0.1 up-to-date Python 3  
django-environ ==0.8.1 0.8.1 up-to-date Python 3  
django-model-utils ==4.2.0 4.2.0 up-to-date Python 3  
django-allauth ==0.47.0 0.47.0 up-to-date Python 3  
django-crispy-forms ==1.13.0 1.13.0 up-to-date Python 3  
crispy-bootstrap5 ==0.6 0.6 up-to-date Python 3  
django-compressor ==3.1 3.1 up-to-date Python 3  
django-redis ==5.2.0 5.2.0 up-to-date Python 3  
djangorestframework ==3.13.1 3.13.1 up-to-date Python 3  
django-cors-headers ==3.11.0 3.11.0 up-to-date Python 3  

{{cookiecutter.project_slug}}/requirements/local.txt


Werkzeug[watchdog] ==2.0.2 2.0.2 up-to-date Python 3  
ipdb ==0.13.9 0.13.9 up-to-date Python 3  
psycopg2 ==2.9.3 2.9.3 up-to-date Python 3  
psycopg2-binary ==2.9.3 2.9.3 up-to-date Python 3  
watchgod ==0.7 0.6 up-to-date Python 3  
mypy ==0.931 0.931 up-to-date Python 3  
django-stubs ==1.9.0 1.9.0 up-to-date Python 3  
pytest ==6.2.5 6.2.5 up-to-date Python 3  
pytest-sugar ==0.9.4 0.9.4 up-to-date Python 3  
djangorestframework-stubs ==1.4.0 1.3.0 up-to-date Python 3  
sphinx ==4.3.2 4.4.0 outdated Python 3  
sphinx-autobuild ==2021.3.14 2021.3.14 up-to-date Python 3  
flake8 ==4.0.1 4.0.1 up-to-date Python 3  
flake8-isort ==4.1.1 4.1.1 up-to-date Python 3  
coverage ==6.2 6.2 up-to-date Python 3  
black ==21.12b0 21.12b0 up-to-date Python 3  
pylint-django ==2.5.0 2.5.0 up-to-date Python 3  
pylint-celery ==0.3 0.3 up-to-date Python 3  
pre-commit ==2.16.0 2.16.0 up-to-date Python 3  
factory-boy ==3.2.1 3.2.1 up-to-date Python 3  
django-debug-toolbar ==3.2.4 3.2.4 up-to-date Python 3  
django-extensions ==3.1.5 3.1.5 up-to-date Python 3  
django-coverage-plugin ==2.0.2 2.0.2 up-to-date Python 3  
pytest-django ==4.5.2 4.5.2 up-to-date Python 3