Python

42244

CVE-2017-1000007

This vulnerability was reviewed by experts

The information on this page was manually curated by our Cybersecurity Intelligence Team.

Created at Jul 17, 2017 Updated at Dec 09, 2022
Scan your Python projects for vulnerabilities →

Advisory

txAWS (all current versions) fail to perform complete certificate verification resulting in vulnerability to MitM attacks and information disclosure.

Affected package

txaws

Latest version: 0.5.0

Async library for EC2, OpenStack, and Eucalyptus

Affected versions

Fixed versions

Vulnerability changelog

This vulnerability has no description

Resources

Do you use this package?

In a few clicks we can scan your Python application, find vulnerabilities and suggest fixes.

Scan your application

Severity Details

CVSS Base Score

MEDIUM 5.9

CVSS v3 Details

MEDIUM 5.9
Attack Vector (AV)
NETWORK
Attack Complexity (AC)
HIGH
Privileges Required (PR)
NONE
User Interaction (UI)
NONE
Scope (S)
UNCHANGED
Confidentiality Impact (C)
HIGH
Integrity Impact (I)
NONE
Availability Availability (A)
NONE

CVSS v2 Details

MEDIUM 4.3
Access Vector (AV)
NETWORK
Access Complexity (AC)
MEDIUM
Authentication (Au)
NONE
Confidentiality Impact (C)
PARTIAL
Integrity Impact (I)
NONE
Availability Impact (A)
NONE