Docs | Support

GreyNoise-Intelligence/pygreynoise

requirements/common.txt


Package Current version Latest version Status Python 3
Click ==8.0.1 8.0.3 outdated Python 3 PR
ansimarkup ==1.4.0 1.4.0 up-to-date Python 3  
cachetools ==4.2.2 4.2.4 outdated Python 3 PR
click-default-group ==1.2.2 1.2.2 up-to-date Python 3  
click-repl ==0.2.0 0.2.0 up-to-date Python 3  
dict2xml ==1.7.0 1.7.0 up-to-date Python 3  
ipaddress ==1.0.23 1.0.23 up-to-date Python 3  
jinja2 ==3.0.1 3.0.3 outdated Python 3 PR
more-itertools ==8.8.0 8.12.0 outdated Python 3 PR
requests ==2.25.1 2.26.0 outdated Python 3 PR
six ==1.16.0 1.16.0 up-to-date Python 3  
structlog ==21.1.0 21.4.0 outdated Python 3 PR

requirements/dev.txt


advbumpversion ==1.2.0 1.2.0 up-to-date Python 3  
ipython ==7.25.0 7.30.1 outdated Python 3 PR
pre-commit ==2.13.0 2.16.0 outdated Python 3 PR
tox ==3.23.1 3.24.4 outdated Python 3 PR

requirements/test.txt


black ==21.6b0 21.12b0 outdated Python 3 PR
flake8 ==3.9.2 4.0.1 outdated Python 3 PR
isort ==5.9.1 5.10.1 outdated Python 3 PR
mock ==4.0.3 4.0.3 up-to-date Python 3  
pylint ==2.9.0 2.12.2 outdated Python 3 PR
pytest-cov ==2.12.1 3.0.0 outdated Python 3 PR
pytest ==6.2.4 6.2.5 outdated Python 3 PR
restructuredtext-lint ==1.3.2 1.3.2 up-to-date Python 3  
twine ==3.4.1 3.7.0 outdated Python 3 PR
yamllint ==1.26.1 1.26.3 outdated Python 3 PR

requirements/docs.txt


Sphinx ==4.0.2 4.3.1 outdated Python 3 PR
sphinx-click ==3.0.1 3.0.2 outdated Python 3 PR
sphinx-rtd-theme ==0.5.2 1.0.0 outdated Python 3 PR