Python

gimme-that

Latest version: v0.3.1

PyUp actively tracks 488,662 Python packages for vulnerabilities to keep your Python environments secure.

Scan your dependencies

Page 1 of 2

0.3.1

What's Changed
* Fix support for factory functions that return a different type by elfjes in https://github.com/elfjes/gimme-that/pull/37


**Full Changelog**: https://github.com/elfjes/gimme-that/compare/v0.3.0...v0.3.1

0.3.0

What's Changed
* Better detection of variadic arguments by elfjes in https://github.com/elfjes/gimme-that/pull/33
* Better support generics and get depedency from lower layers by elfjes in https://github.com/elfjes/gimme-that/pull/34
* Support adding and registering objects for different types by elfjes in https://github.com/elfjes/gimme-that/pull/35
* Support python 3.11 by elfjes in https://github.com/elfjes/gimme-that/pull/36


**Full Changelog**: https://github.com/elfjes/gimme-that/compare/v0.2.3...v0.3.0

0.2.3

What's Changed
* Ignore variadic argument, better signature detection by elfjes in https://github.com/elfjes/gimme-that/pull/31

0.2.2

* Now really fix using kwargs from DependencyInfo by elfjes in https://github.com/elfjes/gimme-that/pull/30

0.2.1

* Fix passing kwargs from DependencyInfo by elfjes in https://github.com/elfjes/gimme-that/pull/29

0.2.0

What's Changed
* Support resolving arbitrary factory functions
* Support for supplying extra keyword arguments to `gimme.that` that are passed to the constructor
* Properly support `__future__.annotations` forward references
* Drop support for python 3.6

Page 1 of 2