Changelogs » Pyflunearyou

PyUp Safety actively tracks 282,845 Python packages for vulnerabilities and notifies you when to upgrade.

Pyflunearyou

2.0.0

🚨 Breaking Changes
  
  - Make aiothttp ClientSession optional (43)
  
  🚀 Features
  
  - Add support for Python 3.9 (49)
  - Make aiothttp ClientSession optional (43)
  
  🧰 Maintenance
  
  - Make Release Drafter aware of breaking changes and maintenance (52)
  - Update poetry to use core back-end (51)
  - Update linting CI step with new pre-commit action (50)
  - Update ujson requirement from >=1.35,<4.0 to >=1.35,<5.0 (48)
  - Update pytest requirement from ^5.4.1 to ^6.0.0 (45)
  - Update ujson requirement from >=1.35,<3.0 to >=1.35,<4.0 (44)
  - Add pre-commit caching to CI (42)
  - Update aresponses requirement from ^1.1.1 to ^2.0.0 (40)
  - Adjust codespell to quiet level 4 (39)
  - Move codecov CI action to v1 (38)
  - Update ujson requirement from ^1.35 to >=1.35,<3.0 (37)
  - Add pre-commit repos for JSON and branch (36)
  - Update msgpack requirement from ^0.6.2 to >=0.6.2,<1.1.0 (34)
  - Remove pre-commit repos from poetry dependencies (33)
  - Consolidate pre-commit commands in CI (32)
  - Combile linting and static analysis into one CI pipeline (31)
  - Bump mypy (in pre-commit) to 0.761 (30)

1.0.7

🧰 Maintenance
  
  - Add shellcheck to CI (29)
  - Move examples to their own folder (28)
  - Replace Makefile with bash scripts (27)
  - Add categories to release drafter (26)

1.0.6

* Add GitHub Action to create and publish a release
  * Update pydocstyle requirement from ^4.0.1 to ^5.0.2 (22)
  * Update pre-commit requirement from ^1.20.0 to ^2.0.1 (23)
  * Update mypy requirement from ^0.740 to ^0.761 (25)
  * Bump pytest to 5.3.5
  * Add codespell to pre-commit (21)
  * Modernize test and fixture framework (20)
  * Speed up CI (19)
  * Add more repos to pre-commit + include bandit (18)

1.0.5

* Updated Makefile
  * Migrate from Travis-CI to GitHub Actions (17)
  * Move from pipenv to virtualenv + poetry (16)
  * Officially support Python 3.8 (15)

1.0.4

* Add Python 3.6-style variable type annotations (14)
  * Switch to f-strings (and remove support for Python 3.5.3) (13)

1.0.3

* Fix incorrect state in CDC data (10)
  * Updated docstrings
  * Rename util to helpers
  * Corrected module usage
  * Updated Makefile and Pipfile

1.0.2

* Remove aiodns from requirements

1.0.1

* Fix a bug with previously-unknown CDC ranges (8)

1.0.0

* Add support for extended data on user endpoint (6)
  * Re-architect client and children (5)

0.1.0

* Add better logging (3)

0.0.2

* Fix bug with CDC status by latitude/longitude (2)

0.0.1

* Create library (1)