Changelogs » Pulumi-random

PyUp Safety actively tracks 316,954 Python packages for vulnerabilities and notifies you when to upgrade.

Pulumi-random

4.2.0

* Upgrade to v3.2.1 of the pulumi-terraform-bridge

4.1.1

* Removal of extra `id` parameters from the schema

4.1.0

* Upgrade to v3.1.0 of the Random Terraform Provider

4.0.0

* Depend on Pulumi 3.0, which includes improvements to Python resource arguments and key translation, Go SDK performance,
  Node SDK performance, general availability of Automation API, and more.

3.2.0

* Upgrade to pulumi-terraform-bridge v2.23.0

3.1.1

* Upgrade to pulumi-terraform-bridge v2.22.1
  **Please Note:** This includes a bug fix to the refresh operation regarding arrays

3.1.0

* Upgrade to pulumi-terraform-bridge v2.21.0
  * Release macOS arm64 binary

3.0.3

* Upgrade to pulumi-terraform-bridge v2.19.0
  **Please Note:** This includes a bug fix that stops mutating resources options in the nodejs provider

3.0.2

* Upgrading pulumi-terraform-bridge to v2.18.1

3.0.1

* Upgrade to v3.0.1 of the Random Terraform Provider

3.0.0

* Upgrade to v3.0.0 of the Random Terraform Provider
  **PLEASE NOTE:**
  * `random.randomId` has had `b64` removed as it was previously deprecated.

2.5.0

* Upgrade to v2.16.0 of pulumi-terraform-bridge
  * Preserve unknowns during provider preview
  * Upgrade NodeJS and Python versions to use Pulumi >= v2.15.0

2.4.4

* Upgrade to pulumi-terraform-bridge v2.15.3

2.4.3

* Upgrade to pulumi-terraform-bridge v2.15.2
  * Upgrade to Pulumi v2.10.2

2.4.2

* Upgrade to pulumi-terraform-bridge v2.13.2
  * This adds support for import specific examples in documentation

2.4.1

* Upgrade to pulumi-terraform-bridge v2.12.1

2.4.0

* Upgrade to Pulumi v2.12.0 and pulumi-terraform-bridge v2.11.0
  * Improving the accuracy of previews leading to a more accurate understanding of what will actually change rather than assuming all output properties will change.
  ** PLEASE NOTE:**
  This new preview functionality can be disabled by setting `PULUMI_DISABLE_PROVIDER_PREVIEW` to `1` or `false`.

2.3.1

* Upgrade to pulumi-terraform-bridge v2.7.3

2.3.0

* Upgrade to Pulumi v2.9.0, which adds type annotations and input/output classes to Python
  * Upgrade to pulumi-terraform-bridge v2.7.2

2.2.0

* Upgrade to v2.3.0 of the Random Terraform Provider

2.1.4

* Publish Go examples in SDK

2.1.3

* Switch to GitHub actions for build

2.1.2

* Upgrade to Pulumi v2.3.0
  * Upgrade to pulumi-terraform-bridge v2.4.0

2.1.1

* Upgrade to pulumi-terraform-bridge v2.3.1

2.1.0

* Upgrade to pulumi-terraform-bridge v2.1.0

2.0.0

* Upgrade to Pulumi v2.0.0
  * Upgrade to pulumi-terraform-bridge v2.0.0

1.7.0

* Upgrade to Pulumi v1.13.1
  * Upgrade to pulumi-terraform-bridge v1.8.4

1.6.0

* Upgrade to Pulumi v1.12.1
  * Upgrade to pulumi-terraform-bridge v1.8.2

1.5.0

* Upgrade to pulumi-terraform-bridge v1.6.4

1.4.0

* Upgrade to pulumi-terraform-bridge v1.5.2

1.3.0

* readme: fix example to create right passwd for RDS
  [64](https://github.com/pulumi/pulumi-random/pull/64)
  * Upgrade to support go 1.13.x
  * Upgrade to pulumi-terraform-bridge v1.4.3

1.2.0

* Add a **preview** .NET SDK

1.1.0

* Regenerate SDK against tf2pulumi 0.6.0
  * Upgrade to v2.2.1 of the Random Terraform Provider

1.0.0

* Use 1.0 version of Pulumi dependency

1.0.0rc.1

* Upgrade pulumi-terraform to 3f206601e7

1.0.0beta.2

___NULL___
  * Upgrade to pulumi-terraform58c7473d08

1.0.0beta.1

* Add `RandomPassword` which behaves like `RandomString` except the ID value stored in the checkpoint is always "none" instead of the underlying value

0.5.8

* Upgrade to pulumi-terraform9db2fc93cd
  * Upgrade to v2.2.0 of the Random Terraform Provider

0.5.7

* Update to pulumi-terraform013b95b1c8

0.5.6

* Fix detailed diffs with nested computed values.

0.5.5

* Communicate detailed information about the difference between a resource's desired and actual state during a Pulumi update

0.5.4

* Add TypeScript type guards for each resource class ([7ace3e9b5f](https://github.com/pulumi/pulumi-terraform/commit/7ace3e9b5f2dcd4692b029ba4b80360582d7949a))
  * Update to pulumi-terraform3635bed3a5 which stops maps containing `.` being treated as nested maps.

0.5.3

* Update to v2.1.2 of the Terraform Random provider

0.5.2

* Update to v2.1.1 of the Terraform Random provider

0.5.1

* Depend on a more recent minimum version of the Pulumi Python SDK

0.5.0

* Updated to the latest version of the `pulumi` SDK
  * BREAKING: This version of the Random provider will not work side-by-side with previous versions

0.4.0

* Add support for the `deleteBeforeReplace` resource option and improved delete-before-replace behaviour introduced in Pulumi v0.16.14

0.3.0

* Add documentation comments to the Node.js SDK

0.1.0

* Initial version of the Random provider