Changelogs » Oxasl

PyUp Safety actively tracks 268,179 Python packages for vulnerabilities and notifies you when to upgrade.

Oxasl

16.04

[oxasl-0.0.3-ubuntu16.tar.gz](https://github.com/ibme-qubic/oxasl/files/2671734/oxasl-0.0.3-ubuntu16.tar.gz)
  
  Centos 7

10.14.1

[oxasl-0.1.1-osx.tar.gz](https://github.com/ibme-qubic/oxasl/files/3072503/oxasl-0.1.1-osx.tar.gz)

10.11.6


        

6.5


        

0.1.1

These development packages include the oxasl and oxasl_ve packages, the fslpy, fabber and veaslc dependencies and a wrapper script to run the pipeline in an fslpython environment
  
  Other required dependencies are  `numpy`, `nibabel`, `six` and `pyaml`. These must be installed separately. In an fslpython environment they should all exist already, with the possible exception of pyaml. To install pyaml into fslpython use:
  
  fslpython -m pip install pyaml --user
  
  If you want to use the HTML reporting feature, `sphinx` is also required. To install into fslpython use:
  
  fslpython -m pip install sphinx --user
  
  The pipeline is under development and has not been battle tested yet. Please contact martin.craigeng.ox.ac.uk with any issues or other feedback.
  
  This release replaces v0.1.0 and includes minor documentation and error handling fixes.

0.0.7

These development packages include the oxasl and oxasl_ve packages, the fslpy, fabber and veaslc dependencies and a wrapper script to run the pipeline in an fslpython environment
  
  Other required dependencies are  `numpy`, `nibabel`, `six` and `pyaml`. These must be installed separately. In an fslpython environment they should all exist already, with the possible exception of pyaml. All can be installed using pip if required, e.g.
  
  pip install pyaml
  
  The pipeline is under development and has not been battle tested yet. Please contact martin.craigeng.ox.ac.uk with any issues or other feedback.
  
  This release replaces v0.0.6 and includes fixes for structural registration and increases the maximum number of iterations in the VEASL decoding plugin to reduce the chance of this failing to converge.

0.0.6

These development packages include the oxasl and oxasl_ve packages, the fslpy, fabber and veaslc dependencies and a wrapper script to run the pipeline in an fslpython environment
  
  Other required dependencies are  `numpy`, `nibabel`, `six` and `pyaml`. These must be installed separately. In an fslpython environment they should all exist already, with the possible exception of pyaml. All can be installed using pip if required, e.g.
  
  pip install pyaml
  
  The pipeline is under development and has not been battle tested yet. Please contact martin.craigeng.ox.ac.uk with any issues or other feedback.
  
  This release includes fixes for reporting of motion parameters, an improved method for combining variances with vessel-encoded data and support for using Fabber via the command line API.

0.0.5

These development packages include the oxasl and oxasl_ve packages, the fslpy, fabber and veaslc dependencies and a wrapper script to run the pipeline in an fslpython environment
  
  Other required dependencies are  `numpy`, `nibabel`, `six` and `pyaml`. These must be installed separately. In an fslpython environment they should all exist already, with the possible exception of pyaml. All can be installed using pip if required, e.g.
  
  pip install pyaml
  
  The pipeline is under development and has not been battle tested yet. Please contact martin.craigeng.ox.ac.uk with any issues or other feedback.
  
  This release fixes incorrect inversion efficiency for vessel-encoded data, fixes to run correctly under FSL6 and adds the option to output variance/std dev.

0.0.4

These development packages include the oxasl and oxasl_ve packages, the fslpy, fabber and veaslc dependencies and a wrapper script to run the pipeline in an fslpython environment
  
  Other required dependencies are  `numpy`, `nibabel`, `six` and `pyaml`. These must be installed separately. In an fslpython environment they should all exist already, with the possible exception of pyaml. All can be installed using pip if required, e.g.
  
  pip install pyaml
  
  The pipeline is under development and has not been battle tested yet. Please contact martin.craigeng.ox.ac.uk with any issues or other feedback.

0.0.3

These development packages include the oxasl and oxasl_ve packages, the fslpy, fabber and veaslc dependencies and a wrapper script to run the pipeline in an fslpython environment
  
  Other required dependencies are  `numpy`, `nibabel`, `six` and `pyaml`. These must be installed separately. In an fslpython environment they should all exist already, with the possible exception of pyaml. All can be installed using pip if required, e.g.
  
  pip install pyaml
  
  The pipeline is under development and has not been battle tested yet. Please contact martin.craigeng.ox.ac.uk with any issues or other feedback.