Changelogs » Maturin

PyUp Safety actively tracks 263,016 Python packages for vulnerabilities and notifies you when to upgrade.

Maturin

0.8.3

Added
  
  * tox is now supported due to a bugfix in the latest version of tox
  * `[tool.maturin]` now supports `sdist-include = ["path/**/*"]` to
  include arbitrary files in source distributions ([296](https://github.com/PyO3/maturin/pull/296)).
  * Add support for PyO3 `0.12`'s `PYO3_PYTHON` environment variable. [331](https://github.com/PyO3/maturin/pull/331)
  
  Fixed
  
  * Fix incorrectly returning full path (not basename) from PEP 517 `build_sdist` hook. This fixes tox support from maturin's side
  * Packages installed with `maturin develop` are now visible to pip and can be uninstalled with pip

0.8.2

Added
  
  * Python 3.8 was added to PATH in the docker image by oconnor663 in [302](https://github.com/PyO3/maturin/pull/302)

0.8.1

Added
  
  * cffi is installed if it's missing and python is running inside a virtualenv.

0.8.0

Added
  
  * There is now a binary wheel for aarch64
  * Warn if there are local dependencies
  
  Fixed
  
  * Omit author_email if `` is not found in authors by evandrocoan in [290](https://github.com/PyO3/maturin/pull/290)

0.7.9

Fixed
  
  * This release includes binary wheels for mac os

0.7.8

Added
  
  * Added support from arm, specifically arm7l, aarch64 by ijl in [273](https://github.com/PyO3/maturin/pull/273)
  * Added support for manylinux2014 by ijl in [273](https://github.com/PyO3/maturin/pull/273)
  
  Fixed
  
  * Remove python 2 from tags by ijl in [254](https://github.com/PyO3/maturin/pull/254)
  * 32-bit wheels didn't work on linux. This has been fixed by dae in [250](https://github.com/PyO3/maturin/pull/250)
  * The path of the RECORD file on windows used a backward slash instead of a forward slash

0.7.7

Added
  
  * The setup.py installer for bootstrapping maturin now checks for cargo instead of failing with a complex error message.
  * Upload errors now show the filesize
  
  Changed
  
  * maturin's metadata now lists a requirement of python3.5 or later to install.

0.7.6


        

0.7.5


        

0.7.4


        

0.7.3


        

0.7.2


        

0.7.1


        

0.7.0


        

0.6.1


        

0.6.0


        

0.5.0


        

0.4.2


        

0.4.1


        

0.4.0


        

0.3.10


        

0.3.9


        

0.3.8


        

0.3.7


        

0.3.6


        

0.3.5


        

0.3.4


        

0.3.3


        

0.3.1


        

0.3.0


        

0.2.0


        

0.1.0

* Initial Release
  
  [Unreleased]: https://github.com/pyo3/maturin/compare/v0.7.6...HEAD