Changelogs » Flake8-isort

PyUp Safety actively tracks 362,670 Python packages for vulnerabilities and notifies you when to upgrade.

Flake8-isort

4.1.2

------------------
  
  - Nothing changed yet.

4.1.1

------------------
  
  - Release py3 only wheels..

4.1.0

------------------
  
  - Support flake8 4.x [g-as]
  
  - Switch from travis-ci to github actions. [g-as]
  
  - Drop python 2.7 support and 3.5 as well [g-as]

4.0.0

------------------
  
  - Nothing changed yet.

4.0.0a0

--------------------
  
  - support isort >= 5 [bnavigator, pkolbus]

3.0.1

------------------
  
  - Work around `FailedToLoadPlugin` exception by requiring `isort` 4.x. Likewise,
  pin the major version of all dependencies, to reduce risk of any future
  incompatibilities.
  [pkolbus]

3.0.0

------------------
  
  - Let `isort` search the configuration, rather than `flake8-isort` try to find it.
  [jnns]

2.9.1

------------------
  
  - Fix flake8 warning.
  [sobolevn]

2.9.0

------------------
  
  - Add ``python3.8`` suport.
  [sobolevn]

2.8.0

------------------
  
  - Look for isort configuration on `.flake8` files as well.
  [JohnHBrock]
  
  - Document how to install `flake8-isort` on conda.
  [marcelotrevisani]
  
  - Look for isort configuration on `pyproject.toml` files as well.
  [sanjioh]

2.7.0

------------------
  
  - Improve the README.
  [barbossa]
  
  - Fix isort output when pipes are used.
  [maerteijn]

2.6.0

------------------
  
  - Use pytest to run tests.
  [gforcada]
  
  - New error code I005 isort foundan unexpected missing import.
  [charettes]
  
  - Add ``isort_show_traceback`` option to show verbose multi-line output
  from ``isort``, turned off by default
  [sobolevn]

2.5

----------------
  
  - Now requires isort >= 4.3.0.
  [jleclanche]

2.4

----------------
  
  - Fix input handling with flake8's --stdin-display-name, and simplify it.
  [blueyed]
  
  - Remove flake8-polyfill dependency.  flake8 >= 3.2.1 is required already, and
  stdin is not read directly anymore.
  [blueyed]

2.3

----------------
  
  - Fix typo.
  [paltman]
  
  - Add tox.ini and .editorconfig to config search.
  [cas--]
  
  - Make this plugin compatible with flake8 hook.
  As the hook copies the files out of tree,
  flake8-isort never finds the correct configuration.
  [jaysonsantos]

2.2.2

------------------
  
  - Workaround for isort bug when skipping files.
  [danpalmer]

2.2.1

------------------
  
  - Release as universal wheel.
  [gforcada]

2.2

----------------
  
  - Support flake8 git hook.
  [sergio-alonso]
  
  - Support python 3.6.
  [gforcada]
  
  - Search configuration on home folder.
  [gforcada]

2.1.3

------------------
  
  - Fix yet another corner case.
  [gforcada]

2.1.2

------------------
  
  - Fix another corner case: ignored files.
  [cas--]

2.1.1

------------------
  
  - Fix corner cases of isort: newlines and grouped imports.
  [cas--]

2.1.0

------------------
  
  - Show the exact line and kind of error,
  rather than a generic message.
  [cas--]

2.0.3

------------------
  
  - Update trove classifiers.
  [gforcada]

2.0.2

------------------
  
  - Add flake8 classifier.
  [sigmavirus24]
  
  - Require flake8 3.2.1.
  flake8 series 3.1.x and 3.2.0 where not reporting flake8-isort errors.
  [gforcada]
  
  - Test on pypy and pypy3.
  [gforcada]
  
  - Fix tests and formatting.
  [gforcada]

2.0.1

------------------
  
  - Fix standard input processing.
  [carljm]

2.0

----------------
  
  - Refactor code to handle flake8 version 3.
  [danpalmer]
  
  - Require flake8 version 3.0.
  [gforcada]

1.3

----------------
  
  - Make error messages clearer.
  [do3cc]
  
  - Use either pep8 or pycodestyle (new name for pep8).
  [Maxim Novikov]
  
  - Fix coveralls.
  [gforcada]

1.2

----------------
  - Allow stdin processing, this way text editor can pass input to flake8.
  [mjacksonw]

1.1.1

------------------
  - Silence isort messages.
  [gforcada]
  
  - Improve wording.
  [gforcada]

1.1

----------------
  - Check for isort configuration on setup.cfg as well.
  [plumdog]

1.0

----------------
  - Check for an isort configuration file.
  [gforcada]

0.2

----------------
  - Fix entry point.
  [gforcada]

0.1.post0

----------------------
  - Release wheels as well.
  [gforcada]

0.1

----------------
  - Initial release
  [gforcada]
  
  - Add all boilerplate files.
  [gforcada]
  
  - Create the flake8 plugin per se.
  [gforcada]