Changelogs » Django-laterpay

PyUp Safety actively tracks 262,358 Python packages for vulnerabilities and notifies you when to upgrade.

Django-laterpay

3.0.0


        

2.0.0

* Added full support for Django 1.8, 1.9 and 1.10
  * Requires Python 2.7 or Python 3.4+
  * Removed official support for Django before 1.8
  * Removed official support for Python 3.3
  * Removed official support for laterpay-client before 4.1
  * Removed deprecated template tags `render_laterpay_header`, `render_laterpay_footer`, `laterpay_subscribe`, and `laterpay_buy` from `djlaterpay`
  * Removed now unused template tags template files `laterpay/inclusion/render_footer.html` and `laterpay/inclusion/render_header.html`

1.3.0

* Loosened version requirement for `laterpay-client` (so it could use v4.0.0 and higher).

1.2.0

* Support and testing for all supported Django versions (1.6 as originally, plus 1.4 and 1.7 and 1.8)
  * Added [logging to LPTokenMiddleware](https://github.com/laterpay/django-laterpay/pull/12)
  * Bumped [laterpay-client](https://github.com/laterpay/laterpay-client-python) dependency to 3.2.1

1.1.0

* Bumped [laterpay-client](https://github.com/laterpay/laterpay-client-python) dependency to 3.1.0
  * Deprecated `djlaterpay.templatetags.laterpay` module
  * Added verification for lptokens [received in middleware](https://github.com/laterpay/django-laterpay/pull/5)
  * MANIFEST.in fixes
  * pep8 fixes

1.0.0

Existence