Changelogs » Dictionaryutils

PyUp Safety actively tracks 268,006 Python packages for vulnerabilities and notifies you when to upgrade.

Dictionaryutils

3.4.0

Generated: 2020-09-23
  
  
  
  Improvements
  - Existing links can be removed by explicitly setting them to None in
  submissions (68)

3.3.0

Generated: 2020-09-09
  
  
  
  New Features
  - Migrate to poetry for dependency management. (64)
  - Removed pipenv, requirements.txt and setup.py. (64)
  - Updated Dockerfile to reflect this change. (64)
  
  Bug Fixes
  - Fix "file_size" type test when "file_size" is not required (66)

3.2.0

Generated: 2020-06-04

3.1.0

Generated: 2020-04-29
  
  
  
  New Features
  - Adds "null" to the types of non-required fields in the dictionary so that
  values can be removed in sheepdog. (59)
  - Added .secinclude to include all relevant files needed for veracode scan.
  (58)
  - Added .secexclude to explicitly remove any unneeded files. (58)
  - Added Jenkinsfile.security for the veracode security organization in
  Jenkins to scan this repo regularly. (58)
  
  Dependency Updates
  - data-simulator to 1.2.0 (59)

3.0.2


        

3.0.1

Generated: 2019-12-23
  
  
  
  Dependency Updates
  - bump jsonschema to 3.2.0 (56)
  
  Bug Fixes
  - Fixes logger and gets rid of annoying "No handlers could be found" logger
  error so we can read the real errors (55)

3.0.0

Generated: 2019-12-05
  
  
  
  New Features
  - ran 2to3 for syntax (54)
  
  Breaking Changes
  - uses python3 (54)
  
  Dependency Updates
  - cdisutils to 1.4.0 (54)
  - gen3datamodel on py3 branch (54)
  - psqlgraph on py3 branch (54)
  - datasimulator on py3 branch (54)

2.0.11

Generated: 2019-11-07
  
  
  
  Bug Fixes
  - Add `cdislogging` to `setup.py`: will fix the missing dependencies if
  nothing else installs this library (53)

2.0.10

Generated: 2019-10-22
  
  
  
  Improvements
  - Print exception when unable to initialize gdcdictionary (52)

2.0.9

Generated: 2019-10-16

2.0.8

Generated: 2019-07-03
  
  
  
  Bug Fixes
  - fixed missing dependency: requests (48)

2.0.7

Generated: 2019-04-04

2.0.6

Generated: 2019-03-25

2.0.5

Generated: 2019-03-22

2.0.4


        

2.0.3


        

2.0.2


        

2.0.1


        

2.0.0


        

1.2.2


        

1.2.1


        

1.2.0


        

1.1.0


        

1.0.0