Changelogs » Assemble

PyUp Safety actively tracks 232,000 Python packages for vulnerabilities and notifies you when to upgrade.

Assemble

0.2.2

-------------
  
  Released on Jul 7th 2016
  
  - Added `assemble commits [--since vX.X.X]`.
  - Fixed Flake8 problems.
  - Fixed forgot to update changelog.
  - Updated `assemble info` with more information & `--compact`.
  - Updated does not require Pandora anymore.
  - Updated with more documentation.

0.2.1

-------------
  
  Released on Jul 1st 2016
  
  - Added documentation to the API.
  - Updated to have no more strict Sphinx builds.
  - Updated requirments.

0.2.0

-------------
  
  Released on Jun 30th 2016
  
  - Added scanning for package path is now configurable.
  - After extended use of `0.1.13` I deemed this project ready for it's `0.2` phase.

0.1.13

--------------
  
  Released on Feb 9th 2016
  
  - Updated requirements.
  - Fixed copy of environment.

0.1.12

--------------
  
  Released on Feb 9th 2016
  
  - Added `coveralls` call to run on `test` when *.coveralls.yml* is present.
  - Updated requirements.
  - Fixed running commands will now copy your current environment.

0.1.11

--------------
  
  Released on Feb 8th 2016
  
  - Added check GIT is clean to `publish`.

0.1.10

--------------
  
  Released on Feb 8th 2016
  
  - Fixed wrong default value for some of the CLI commands.

0.1.9

-------------
  
  Released on Feb 8th 2016
  
  - Updated CLI documentation.
  - Updated the Assemble API to be more flexible.
  - Updated to require less packages.
  - Fixed some usability bugs.

0.1.8

-------------
  
  Released on Feb 7th 2016
  
  - Added automatic install_requires to the setup call of your package.

0.1.7

-------------
  
  Released on Feb 4th 2016
  
  - Added `requirements-scan` command.
  - Added extra options (--major/-x, --minor/-y, --patch/-p) to `version` command.
  - Fixed scanning for GIT version to be quiet.

0.1.6

-------------
  
  Released on Feb 1st 2016
  
  - Added `sphinx.ext.coverage`.
  - Added auto-rebuild of tox environment on requirements change.
  - Updated requirements to match.
  - Updated tox.ini.
  - Fixed Flake8 problems.

0.1.5

-------------
  
  Released on Jan 28th 2016
  
  - Updated documentation (other package stuff).

0.1.4

-------------
  
  Released on Jan 28th 2016
  
  - Added `upload-documentation` command.

0.1.3

-------------
  
  Released on Jan 28th 2016
  
  - Removed the `Version` requirement, because it doesn't work on Python 3.

0.1.2

-------------
  
  Released on Jan 28th 2016
  
  - Assemble is now ready to Assemble packages.

0.1

-----------
  
  Released on Jan 28th 2016
  
  - Initial release