Changelogs » Argopt

PyUp Safety actively tracks 263,166 Python packages for vulnerabilities and notifies you when to upgrade.

Argopt

0.6.0

- fix escaped chars in regex
  - add `.[dev]` <- `requirements-dev.txt`
  - update test framework
  - complete CI framework overhaul
  + fix py26 tests
  + auto-release to PyPI

0.5.0

- allow `ARG` format (5)
  - remove `argparse` dependency for `py>=2.7` (6)
  - add unit tests
  - fix CI py26 tests

0.4.0

- support `epilog`ue
  - ignore section titles (usage|options|arguments): when not at start-of-line
  - update documentation and CI tests

0.3.4

- warn about duplicate options
  - epilog support (2)
  - exposed default `formatter_class=argparse.RawDescriptionHelpFormatter`
  - py26 `argparse` dependency
  - exposed default `logLevel=logging.NOTSET`

0.3.3

- added python 2.6 support
  - update examples and documentation
  - add tests (py3.6, pypy3)
  - exposed `DictAttrWrap`

0.3.1

- default positional arguments [feature]
  - `-v` and `--version` conflict resolution [feature]
  - update documentation
  - update examples
  - coverage, tests and misc tidying

0.3.0


        

0.1.0

First PyPi release
  - docstring to `argparse`
  - inspired by [`docopt`](https://github.com/docopt/docopt)
  - extension support
  - default arguments
  - type specifiers