Changelogs » Adafruit-circuitpython-epd

Adafruit-circuitpython-epd

2.6.1

To use in CircuitPython, simply install the [Adafruit CircuitPython bundle](https://circuitpython.org/libraries).

To use in CPython, `pip3 install adafruit-circuitpython-epd`.

Read the [docs](http://circuitpython.readthedocs.io/projects/epd/en/latest/) for info on how to use it.

2.6.0

We have upgraded Pylint checks to use the latest version of Pylint and implemented usage of Black Python formatting. This does not change the functionality of the code - it is designed to bring it up to current standards and make it more readable.

* Remove pinned Pylint version number from build.yml file
* Synced `.pylintrc` file to match Adafruit standard
* Ran upgraded Pylint and applied any changes or new disables necessary
* Ran Black formatter and allowed application of changes across entire repo

For more information on using Pylint and Black on your code, check out [this guide on working with Pylint and Black](https://learn.adafruit.com/improve-your-code-with-pylint)

To use in CircuitPython, simply install the [Adafruit CircuitPython bundle](https://circuitpython.org/libraries).

To use in CPython, `pip3 install adafruit-circuitpython-epd`.

Read the [docs](http://circuitpython.readthedocs.io/projects/epd/en/latest/) for info on how to use it.

2.5.2

This release includes:
* reduces load on the CPU for SBCs. Thanks mariovisic

To use in CircuitPython, simply install the [Adafruit CircuitPython bundle](https://circuitpython.org/libraries).

To use in CPython, `pip3 install adafruit-circuitpython-epd`.

Read the [docs](http://circuitpython.readthedocs.io/projects/epd/en/latest/) for info on how to use it.

2.5.1

This release includes:
* Migrating this repository from Travis to GitHub Actions. This has no effect on the behavior of the code itself.

To use in CircuitPython, simply install the [Adafruit CircuitPython bundle](https://circuitpython.org/libraries).

To use in CPython, `pip3 install adafruit-circuitpython-epd`.

Read the [docs](http://circuitpython.readthedocs.io/projects/epd/en/latest/) for info on how to use it.

2.5.0

To use in CircuitPython, simply install the [Adafruit CircuitPython bundle](https://github.com/adafruit/Adafruit_CircuitPython_Bundle).

To use in CPython, `pip install adafruit-circuitpython-epd`.

Read the [docs](http://circuitpython.readthedocs.io/projects/epd/en/latest/) for info on how to use it.

2.4.2

To use in CircuitPython, simply install the [Adafruit CircuitPython bundle](https://github.com/adafruit/Adafruit_CircuitPython_Bundle).

To use in CPython, `pip install adafruit-circuitpython-epd`.

Read the [docs](http://circuitpython.readthedocs.io/projects/epd/en/latest/) for info on how to use it.

2.4.1

To make this compatible with `circup`, proper version and Repo URLs were added.

To use in CircuitPython, simply install the [Adafruit CircuitPython bundle](https://github.com/adafruit/Adafruit_CircuitPython_Bundle).

To use in CPython, `pip install adafruit-circuitpython-epd`.

Read the [docs](http://circuitpython.readthedocs.io/projects/epd/en/latest/) for info on how to use it.

2.4.0

Fixed Issues 21 and 22 .  The prior version did not release EPD SRAM CS_pin between updates.  As a result, sharing the SPI lines with another device would cause miscommunication.  Also,  within the EPD board, there was miscommunication which caused the fill logic to fail.  Both problem were fixed with this change.

To use in CircuitPython, simply install the [Adafruit CircuitPython bundle](https://github.com/adafruit/Adafruit_CircuitPython_Bundle).

To use in CPython, `pip install adafruit-circuitpython-epd`.

Read the [docs](http://circuitpython.readthedocs.io/projects/epd/en/latest/) for info on how to use it.

* Note, this is 2.03 re-released as 2.4.0 to fit proper semver.

2.0.2

There was an issue with CircuitPython 4.0.0 RC2 and later where byte checking was removed that caused the EPD library to fail. This fix allows the library to be used with the latest version of CircuitPython. Thanks mrmcwethy

To use in CircuitPython, simply install the [Adafruit CircuitPython bundle](https://github.com/adafruit/Adafruit_CircuitPython_Bundle).

To use in CPython, `pip install adafruit-circuitpython-epd`.

Read the [docs](http://circuitpython.readthedocs.io/projects/epd/en/latest/) for info on how to use it.

2.0.1

* Updated example usage in README

To use in CircuitPython, simply install the [Adafruit CircuitPython bundle](https://github.com/adafruit/Adafruit_CircuitPython_Bundle).

To use in CPython, `pip install adafruit-circuitpython-epd`.

Read the [docs](http://circuitpython.readthedocs.io/projects/epd/en/latest/) for info on how to use it.

2.0.0

This also made it possible to add more displays, now has 2.7" tricolor support! Thanks ladyada

To use in CircuitPython, simply install the [Adafruit CircuitPython bundle](https://github.com/adafruit/Adafruit_CircuitPython_Bundle).

To use in CPython, `pip install adafruit-circuitpython-epd`.

Read the [docs](http://circuitpython.readthedocs.io/projects/epd/en/latest/) for info on how to use it.

1.2.1

To use in CircuitPython, simply install the [Adafruit CircuitPython bundle](https://github.com/adafruit/Adafruit_CircuitPython_Bundle).

To use in CPython, `pip install adafruit-circuitpython-epd`.

Read the [docs](http://circuitpython.readthedocs.io/projects/epd/en/latest/) for info on how to use it.

1.2.0

Also update to division to make library faster. Added example for RPi.

To use in CircuitPython, simply install the [Adafruit CircuitPython bundle](https://github.com/adafruit/Adafruit_CircuitPython_Bundle).

To use in CPython, `pip install adafruit-circuitpython-epd`.

Read the [docs](http://circuitpython.readthedocs.io/projects/epd/en/latest/) for info on how to use it.

1.1.0

- Added `setup.py`
- Added PyPI release info to `.travis.yml`
- Updated `requirements.txt`
- Added a more comprehensive `.gitignore`

To use in CircuitPython, simply install the [Adafruit CircuitPython bundle](https://github.com/adafruit/Adafruit_CircuitPython_Bundle).

To use in CPython, `pip install adafruit-circuitpython-epd`.

Read the [docs](http://circuitpython.readthedocs.io/projects/epd/en/latest/) for info on how to use it.

1.0.0